En resumen
- CVE-2025-27146 es una vulnerabilidad MEDIO (CVSS 4.3) que afecta a matrix irc bridge (matrix), matrix-appservice-irc.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.40%, mayor que el 33.9% de las vulnerabilidades.
- Solución: actualizar a 3.0.4 o posterior.
Description
Impact
The matrix-appservice-irc bridge up to version 3.0.3 contains a vulnerability which can lead to arbitrary IRC command execution as the puppeted user. The attacker can only inject commands executed as their own IRC user.
Patches
The vulnerability has been patched in matrix-appservice-irc version 3.0.4.
For more information
If you have any questions or comments about this advisory, please email us at security at matrix.org.
NVD description
matrix-appservice-irc is a Node.js IRC bridge for Matrix. The matrix-appservice-irc bridge up to version 3.0.3 contains a vulnerability which can lead to arbitrary IRC command execution as the puppeted user. The attacker can only inject commands executed as their own IRC user. The vulnerability has been patched in matrix-appservice-irc version 3.0.4.
Más vulnerabilidades de matrix irc bridge
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free