En resumen
- CVE-2025-30148 es una vulnerabilidad MEDIO (CVSS 5.4) que afecta a silverstripe/framework, framework (silverstripe).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.29%, mayor que el 21.8% de las vulnerabilidades.
- Solución: actualizar a 5.3.23 o posterior.
Description
Impact
A bad actor with access to edit content in the CMS could send a specifically crafted encoded payload to the server, which could be used to inject a JavaScript payload on the front end of the site. The payload would be sanitised on the client-side, but server-side sanitisation doesn't catch it.
The server-side sanitisation logic has been updated to sanitise against this attack.
Reported by
James Nicoll from Fujitsu Cyber
References
NVD description
Silverstripe Framework is a PHP framework which powers the Silverstripe CMS. Prior to 5.3.23, bad actor with access to edit content in the CMS could send a specifically crafted encoded payload to the server, which could be used to inject a JavaScript payload on the front end of the site. The payload would be sanitized on the client-side, but server-side sanitization doesn't catch it. The server-side sanitization logic has been updated to sanitize against this attack. This vulnerability is fixed in 5.3.23.
Más vulnerabilidades de silverstripe/framework
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free