En resumen
- CVE-2025-32957 es una vulnerabilidad ALTO (CVSS 7.2) que afecta a baserproject/basercms, basercms (basercms).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.59%, mayor que el 48.1% de las vulnerabilidades.
- Solución: actualizar a 5.2.3 o posterior.
Description
Details
The application's restore function allows users to upload a .zip file, which is then automatically extracted. A PHP file inside the archive is included using require_once without validating or restricting the filename. An attacker can craft a malicious PHP file within the zip and achieve arbitrary code execution when it is included.
Vector: Malicious ZIP upload + insecure require_once
PoC
- Restore backup
- Load file shell (insecure
require_once)
Impact
Remote Code Execution (RCE)
NVD description
baserCMS is a website development framework. Prior to version 5.2.3, the application's restore function allows users to upload a .zip file, which is then automatically extracted. A PHP file inside the archive is included using require_once without validating or restricting the filename. An attacker can craft a malicious PHP file within the zip and achieve arbitrary code execution when it is included. This issue has been patched in version 5.2.3.
Más vulnerabilidades de baserproject/basercms
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free