En resumen
- CVE-2025-3930 es una vulnerabilidad MEDIO (CVSS 6.3) que afecta a @strapi/strapi.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.69%, mayor que el 53.0% de las vulnerabilidades.
- Solución: actualizar a 5.24.1 o posterior.
| Package | Affected versions | Patched versions |
|---|
| @strapi/strapi npm | < 5.24.1
| 5.24.1
|
Description
Strapi uses JSON Web Tokens (JWT) for authentication. After logout or account deactivation, the JWT is not invalidated, which allows an attacker who has stolen or intercepted the token to freely reuse it until its expiration date (which is set to 30 days by default, but can be changed). The existence of /admin/renew-token endpoint allows anyone to renew near-expiration tokens indefinitely, further increasing the impact of this attack. This issue has been fixed in version 5.24.1.
NVD description
Strapi uses JSON Web Tokens (JWT) for authentication. After logout or account deactivation, the JWT is not invalidated, which allows an attacker who has stolen or intercepted the token to freely reuse it until its expiration date (which is set to 30 days by default, but can be changed).
The existence of /admin/renew-token endpoint allows anyone to renew near-expiration tokens indefinitely, further increasing the impact of this attack.
This issue has been fixed in version 5.24.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free