En resumen
- CVE-2025-44021 es una vulnerabilidad BAJO (CVSS 2.8) que afecta a ironic.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.19%, mayor que el 8.7% de las vulnerabilidades.
- Solución: actualizar a 26.1.1, 29.0.1, 24.1.3 o posterior.
| Package | Affected versions | Patched versions |
|---|
| ironic PyPI | ≥ 25.0.0, < 26.1.1≥ 27.0.0, < 29.0.1< 24.1.3
| 26.1.129.0.124.1.3
|
Description
OpenStack Ironic before 29.0.1 can write unintended files to a target node disk during image handling (if a deployment was performed via the API). A malicious project assigned as a node owner can provide a path to any local file (readable by ironic-conductor), which may then be written to the target node disk. This is difficult to exploit in practice, because a node deployed in this manner should never reach the ACTIVE state, but it still represents a danger in environments running with non-default, insecure configurations such as with automated cleaning disabled. The fixed versions are 24.1.3, 26.1.1, and 29.0.1.
NVD description
OpenStack Ironic before 29.0.1 can write unintended files to a target node disk during image handling (if a deployment was performed via the API). A malicious project assigned as a node owner can provide a path to any local file (readable by ironic-conductor), which may then be written to the target node disk. This is difficult to exploit in practice, because a node deployed in this manner should never reach the ACTIVE state, but it still represents a danger in environments running with non-default, insecure configurations such as with automated cleaning disabled. The fixed versions are 24.1.3, 26.1.1, and 29.0.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free