En resumen
- CVE-2025-47951 es una vulnerabilidad MEDIO (CVSS 4.9) que afecta a weblate, weblate (weblate).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.27%, mayor que el 18.5% de las vulnerabilidades.
- Solución: actualizar a 5.12 o posterior.
| Package | Affected versions | Patched versions |
|---|
| weblate PyPI | < 5.12
| 5.12
|
| weblate | < 5.12
| 5.12
|
Description
Impact
The verification of the second factor was not subject to rate limiting. The absence of rate limiting on the second factor endpoint allows an attacker with valid credentials to automate OTP guessing.
Patches
This issue has been addressed in Weblate 5.12 via https://github.com/WeblateOrg/weblate/pull/14918.
References
Thanks to obscuredeer for reporting this issue at HackerOne.
NVD description
Weblate is a web based localization tool. Prior to version 5.12, the verification of the second factor was not subject to rate limiting. The absence of rate limiting on the second factor endpoint allows an attacker with valid credentials to automate OTP guessing. This issue has been patched in version 5.12.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free