En resumen
- CVE-2025-49596 es una vulnerabilidad CRÍTICO (CVSS 9.4) que afecta a @modelcontextprotocol/inspector.
- Probabilidad de explotación en los próximos 30 días (EPSS): 44.5%, mayor que el 98.8% de las vulnerabilidades.
- Solución: actualizar a 0.14.1 o posterior.
Description
Versions of MCP Inspector below 0.14.1 are vulnerable to remote code execution due to lack of authentication between the Inspector client and proxy, allowing unauthenticated requests to launch MCP commands over stdio. Users should immediately upgrade to version 0.14.1 or later to address these vulnerabilities.
Credit: Rémy Marot [email protected]
NVD description
The MCP inspector is a developer tool for testing and debugging MCP servers. Versions of MCP Inspector below 0.14.1 are vulnerable to remote code execution due to lack of authentication between the Inspector client and proxy, allowing unauthenticated requests to launch MCP commands over stdio. Users should immediately upgrade to version 0.14.1 or later to address these vulnerabilities.
Más vulnerabilidades de @modelcontextprotocol/inspector
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free