En resumen
- CVE-2025-50213 es una vulnerabilidad CRÍTICO (CVSS 9.8) que afecta a apache-airflow-providers-snowflake, apache-airflow-providers-snowflake (apache).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.77%, mayor que el 55.8% de las vulnerabilidades.
- Solución: actualizar a 6.4.0 o posterior.
Description
Failure to Sanitize Special Elements into a Different Plane (Special Element Injection) vulnerability in Apache Airflow Providers Snowflake.
This issue affects Apache Airflow Providers Snowflake: before 6.4.0.
Sanitation of table and stage parameters were added in CopyFromExternalStageToSnowflakeOperator to prevent SQL injection
Users are recommended to upgrade to version 6.4.0, which fixes the issue.
NVD description
Failure to Sanitize Special Elements into a Different Plane (Special Element Injection) vulnerability in Apache Airflow Providers Snowflake.
This issue affects Apache Airflow Providers Snowflake: before 6.4.0.
Sanitation of table and stage parameters were added in CopyFromExternalStageToSnowflakeOperator to prevent SQL injection
Users are recommended to upgrade to version 6.4.0, which fixes the issue.
Más vulnerabilidades de apache-airflow-providers-snowflake
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free