En resumen
- CVE-2025-54384 es una vulnerabilidad MEDIO (CVSS 6.3) que afecta a ckan.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.23%, mayor que el 13.3% de las vulnerabilidades.
- Solución: actualizar a 2.11.4, 2.10.9 o posterior.
| Package | Affected versions | Patched versions |
|---|
| ckan PyPI | ≥ 2.11.0, < 2.11.4< 2.10.9
| 2.11.42.10.9
|
Description
Impact
The helpers.markdown_extract() function did not perform sufficient sanitization of input data before wrapping in an HTML literal element. This helper is used to render user-provided data on dataset, resource, organization or group pages (plus any page provided by an extension that used that helper function), leading to a potential XSS vector.
Patches
This vulnerability has been fixed in CKAN 2.10.9 and 2.11.4
NVD description
CKAN is an open-source DMS (data management system) for powering data hubs and data portals. Prior to 2.10.9 and 2.11.4, the helpers.markdown_extract() function did not perform sufficient sanitization of input data before wrapping in an HTML literal element. This helper is used to render user-provided data on dataset, resource, organization or group pages (plus any page provided by an extension that used that helper function), leading to a potential XSS vector. This vulnerability has been fixed in CKAN 2.10.9 and 2.11.4.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free