En resumen
- CVE-2025-54575 es una vulnerabilidad MEDIO (CVSS 5.3) que afecta a SixLabors.ImageSharp.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.45%, mayor que el 39.0% de las vulnerabilidades.
- Solución: actualizar a 3.1.11, 2.1.11 o posterior.
| Package | Affected versions | Patched versions |
|---|
| SixLabors.ImageSharp NuGet | ≥ 3.0.0, < 3.1.11< 2.1.11
| 3.1.112.1.11
|
Description
Impact
A specially crafted GIF file containing a malformed comment extension block (with a missing block terminator) can cause the ImageSharp GIF decoder to enter an infinite loop while attempting to skip the block. This leads to a denial of service. Applications processing untrusted GIF input should upgrade to a patched version.
Patches
The problem has been patched. All users are advised to upgrade to v3.1.11 or v2.1.11.
Workarounds
None.
NVD description
ImageSharp is a 2D graphics library. In versions below 2.1.11 and 3.0.0 through 3.1.10, a specially crafted GIF file containing a malformed comment extension block (with a missing block terminator) can cause the ImageSharp GIF decoder to enter an infinite loop while attempting to skip the block. This leads to a denial of service. Applications processing untrusted GIF input should upgrade to a patched version. This issue is fixed in versions 2.1.11 and 3.1.11.
Más vulnerabilidades de SixLabors.ImageSharp
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free