En resumen
- CVE-2025-55197 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a pypdf, pypdf (py-pdf).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.48%, mayor que el 41.2% de las vulnerabilidades.
- Solución: actualizar a 6.0.0 o posterior.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.0.0
| 6.0.0
|
| pypdf | < 6.0.0
| 6.0.0
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to the RAM being exhausted. This requires just reading the file if a series of FlateDecode filters is used on a malicious cross-reference stream. Other content streams are affected on explicit access.
Patches
This has been fixed in pypdf==6.0.0.
Workarounds
If you cannot upgrade yet, you might want to implement the workaround for pypdf.filters.decompress yourself: https://github.com/py-pdf/pypdf/blob/0dd57738bbdcdb63f0fb43d8a6b3d222b6946595/pypdf/filters.py#L72-L143
References
This issue has been reported in #3429 and fixed in #3430.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to version 6.0.0, an attacker can craft a PDF which leads to the RAM being exhausted. This requires just reading the file if a series of FlateDecode filters is used on a malicious cross-reference stream. Other content streams are affected on explicit access. This issue has been fixed in 6.0.0. If an update is not possible, a workaround involves including the fixed code from pypdf.filters.decompress into the existing filters file.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free