| Package | Affected versions | Patched versions |
|---|---|---|
| next.js | ≥ 15.0.0, < 15.4.5< 14.2.31 | 15.4.514.2.31 |
| next | ≥ 0.9.9, < 14.2.31≥ 15.0.0, < 15.4.5 | 14.2.3115.4.5 |
A vulnerability in Next.js Image Optimization has been fixed in v15.4.5 and v14.2.31. When images returned from API routes vary based on request headers (such as Cookie or Authorization), these responses could be incorrectly cached and served to unauthorized users due to a cache key confusion bug.
All users are encouraged to upgrade if they use API routes to serve images that depend on request headers and have image optimization enabled.
More details at Vercel Changelog
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free