En resumen
- CVE-2025-59837 es una vulnerabilidad ALTO (CVSS 7.2) que afecta a astro (astro), astro.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.35%, mayor que el 28.8% de las vulnerabilidades.
- Solución: actualizar a 5.13.10 o posterior.
| Package | Affected versions | Patched versions |
|---|
| astro | ≥ 5.13.4, < 5.13.10
| 5.13.10
|
| astro npm | ≥ 5.13.4, < 5.13.10
| 5.13.10
|
Description
NVD description
Astro is a web framework that includes an image proxy. In versions 5.13.4 and later before 5.13.10, the image proxy domain validation can be bypassed by using backslashes in the href parameter, allowing server-side requests to arbitrary URLs. This can lead to server-side request forgery (SSRF) and potentially cross-site scripting (XSS). This vulnerability exists due to an incomplete fix for CVE-2025-58179. Fixed in 5.13.10.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free