En resumen
- CVE-2025-6011 es una vulnerabilidad BAJO (CVSS 3.7) que afecta a github.com/hashicorp/vault, vault (hashicorp).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.36%, mayor que el 29.4% de las vulnerabilidades.
- Solución: actualizar a 1.20.1, 1.18.12, 1.19.7, 1.16.23 o posterior.
| Package | Affected versions | Patched versions |
|---|
| github.com/hashicorp/vault Go | < 1.20.1
| 1.20.1
|
| vault | = 1.20.0≥ 1.17.0, < 1.18.12≥ 1.19.0, < 1.19.7< 1.16.23< 1.20.1
| 1.18.121.19.71.16.231.20.1
|
Description
A timing side channel in Vault and Vault Enterprise’s (“Vault”) userpass auth method allowed an attacker to distinguish between existing and non-existing users, and potentially enumerate valid usernames for Vault’s Userpass auth method. Fixed in Vault Community Edition 1.20.1 and Vault Enterprise 1.20.1, 1.19.7, 1.18.12, and 1.16.23.
NVD description
A timing side channel in Vault and Vault Enterprise’s (“Vault”) userpass auth method allowed an attacker to distinguish between existing and non-existing users, and potentially enumerate valid usernames for Vault’s Userpass auth method. Fixed in Vault Community Edition 1.20.1 and Vault Enterprise 1.20.1, 1.19.7, 1.18.12, and 1.16.23.
Más vulnerabilidades de github.com/hashicorp/vault
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free