En resumen
- CVE-2025-6167 es una vulnerabilidad CRÍTICO (CVSS 9.8) que afecta a python-a2a, python a2a (themanojdesai).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.77%, mayor que el 55.5% de las vulnerabilidades.
- Solución: actualizar a 0.5.6 o posterior.
Description
A vulnerability classified as critical has been found in themanojdesai python-a2a up to 0.5.5. Affected is the function create_workflow of the file python_a2a/agent_flow/server/api.py. The manipulation leads to path traversal. Upgrading to version 0.5.6 is able to address this issue. It is recommended to upgrade the affected component.
NVD description
A vulnerability classified as critical has been found in themanojdesai python-a2a up to 0.5.5. Affected is the function create_workflow of the file python_a2a/agent_flow/server/api.py. The manipulation leads to path traversal. Upgrading to version 0.5.6 is able to address this issue. It is recommended to upgrade the affected component.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free