En resumen
- CVE-2025-62374 es una vulnerabilidad MEDIO (CVSS 6.4) que afecta a parse.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.41%, mayor que el 35.3% de las vulnerabilidades.
- Solución: actualizar a 7.0.0 o posterior.
| Package | Affected versions | Patched versions |
|---|
| parse npm | < 7.0.0
| 7.0.0
|
Description
Summary
Prototype pollution capabilities on various APIs.
Details
Injection of malicious payload allows attacker to remotely execute arbitrary code. Parse.Object and internal APIs are affected, specifically:
ParseObject.fromJSON
ParseObject.pin
ParseObject.registerSubclass
ObjectStateMutations (internal)
encode/decode (internal)
PoC
Demonstrative tests added as part of the fix.
References
NVD description
Parse Javascript SDK provides access to the powerful Parse Server backend from your JavaScript app. Prior to 7.0.0, injection of malicious payload allows attacker to remotely execute arbitrary code. ParseObject.fromJSON, ParseObject.pin, ParseObject.registerSubclass, ObjectStateMutations (internal), and encode/decode (internal) are affected. This vulnerability is fixed in 7.0.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free