En resumen
- CVE-2025-65995 es una vulnerabilidad MEDIO (CVSS 6.5) que afecta a apache-airflow, airflow (apache).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.89%, mayor que el 59.3% de las vulnerabilidades.
- Solución: actualizar a 3.1.5rc1, 2.11.1, 3.1.4 o posterior.
| Package | Affected versions | Patched versions |
|---|
| apache-airflow PyPI | ≥ 3.0.0b1, < 3.1.5rc1< 2.11.1
| 3.1.5rc12.11.1
|
| airflow | ≥ 3.0.0, < 3.1.4< 2.11.1
| 3.1.42.11.1
|
Description
When a DAG failed during parsing, Airflow’s error-reporting in the UI could include the full kwargs passed to the operators. If those kwargs contained sensitive values (such as secrets), they might be exposed in the UI tracebacks to authenticated users who had permission to view that DAG.
The issue has been fixed in Airflow 3.1.5rc1 and 2.11.1, and users are strongly advised to upgrade to prevent potential disclosure of sensitive information.
NVD description
When a DAG failed during parsing, Airflow’s error-reporting in the UI could include the full kwargs passed to the operators. If those kwargs contained sensitive values (such as secrets), they might be exposed in the UI tracebacks to authenticated users who had permission to view that DAG.
The issue has been fixed in Airflow 3.1.4 and 2.11.1, and users are strongly advised to upgrade to prevent potential disclosure of sensitive information.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free