En resumen
- CVE-2025-66336 es una vulnerabilidad ALTO (CVSS 8.1) que afecta a doris-mcp-server, doris mcp server (apache).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.56%, mayor que el 46.8% de las vulnerabilidades.
- Solución: actualizar a 0.6.1 o posterior.
Description
Apache Doris MCP Server contains a SQL injection vulnerability in a metadata query path. A user-controlled database name is directly interpolated into a SQL query, and the query is executed without passing the caller's authorization context. This may allow an authenticated attacker, or an anonymous attacker if authentication is disabled, to bypass SQL security validation and access metadata outside the intended database scope.
Affected users are recommended to upgrade to Doris version 0.6.1 or later, which fixes the issue.
NVD description
Apache Doris MCP Server contains a SQL injection vulnerability in a metadata query path. A user-controlled database name is directly interpolated into a SQL query, and the query is executed without passing the caller's authorization context. This may allow an authenticated attacker, or an anonymous attacker if authentication is disabled, to bypass SQL security validation and access metadata outside the intended database scope.
Affected users are recommended to upgrade to Doris version 0.6.1 or later, which fixes the issue.
Más vulnerabilidades de doris-mcp-server
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free