En resumen
- CVE-2025-66567 es una vulnerabilidad CRÍTICO (CVSS 9.1) que afecta a ruby-saml, ruby-saml (onelogin).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.42%, mayor que el 36.0% de las vulnerabilidades.
- Solución: actualizar a 1.18.0 o posterior.
| Package | Affected versions | Patched versions |
|---|
| ruby-saml RubyGems | < 1.18.0
| 1.18.0
|
| ruby-saml | < 1.18.0
| 1.18.0
|
Description
Summary
Ruby-saml up to and including 1.12.4, there is an authentication bypass vulnerability because of an incomplete fix for CVE-2025-25292. ReXML and Nokogiri parse XML differently, the parsers can generate entirely different document structures from the same XML input. That allows an attacker to be able to execute a Signature Wrapping attack. The vulnerability does not affect the version 1.18.0.
Impact
That allows an attacker to be able to execute a Signature Wrapping attack and bypass the authentication
NVD description
The ruby-saml library is for implementing the client side of a SAML authorization. ruby-saml versions up to and including 1.12.4 contain an authentication bypass vulnerability due to an incomplete fix for CVE-2025-25292. ReXML and Nokogiri parse XML differently, generating entirely different document structures from the same input. This allows an attacker to execute a Signature Wrapping attack. This issue is fixed in version 1.18.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free