En resumen
- CVE-2025-67746 es una vulnerabilidad MEDIO (CVSS 4.3) que afecta a composer/composer, composer (getcomposer).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.45%, mayor que el 39.4% de las vulnerabilidades.
- Solución: actualizar a 2.2.26, 2.9.3 o posterior.
| Package | Affected versions | Patched versions |
|---|
| composer/composer Packagist | ≥ 2.0.0, < 2.2.26≥ 2.3.0, < 2.9.3
| 2.2.262.9.3
|
| composer | ≥ 2.0.0, < 2.2.26≥ 2.3.0, < 2.9.3
| 2.2.262.9.3
|
Description
Impact
Attackers controlling remote sources that Composer downloads from might in some way inject ANSI control characters in the terminal output of various Composer commands, causing mangled output and potentially leading to confusion or DoS of the terminal application.
There is no proven exploit and this has thus a low severity but Composer still published a CVE as it has potential for abuse, and Composer wants to be on the safe side informing users that they should upgrade.
Patches
2.2.26 for 2.2 LTS or 2.9.3 for mainline.
NVD description
Composer is a dependency manager for PHP. In versions on the 2.x branch prior to 2.2.26 and 2.9.3, attackers controlling remote sources that Composer downloads from might in some way inject ANSI control characters in the terminal output of various Composer commands, causing mangled output and potentially leading to confusion or DoS of the terminal application. There is no proven exploit and this has thus a low severity but we still publish a CVE as it has potential for abuse, and we want to be on the safe side informing users that they should upgrade. Versions 2.2.26 and 2.9.3 contain a patch for the issue.
Más vulnerabilidades de composer/composer
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free