En resumen
- CVE-2026-0540 es una vulnerabilidad MEDIO (CVSS 6.1) que afecta a dompurify (cure53), dompurify.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.39%, mayor que el 32.9% de las vulnerabilidades.
- Solución: actualizar a 2.5.9, 3.3.2 o posterior.
| Package | Affected versions | Patched versions |
|---|
| dompurify | ≥ 2.5.3, ≤ 2.5.8≥ 3.1.3, ≤ 3.3.1
| No fix yet |
| dompurify npm | ≥ 2.5.3, < 2.5.9≥ 3.1.3, < 3.3.2
| 2.5.93.3.2
|
Description
DOMPurify 3.1.3 through 3.3.1 and 2.5.3 through 2.5.8, fixed in 2.5.9 and 3.3.2, contain a cross-site scripting vulnerability that allows attackers to bypass attribute sanitization by exploiting five missing rawtext elements (noscript, xmp, noembed, noframes, iframe) in the SAFE_FOR_XML regex. Attackers can include payloads like </noscript><img src=x onerror=alert(1)> in attribute values to execute JavaScript when sanitized output is placed inside these unprotected rawtext contexts.
NVD description
DOMPurify 3.1.3 through 3.3.1 and 2.5.3 through 2.5.8, fixed in commit 2726c74, contain a cross-site scripting vulnerability that allows attackers to bypass attribute sanitization by exploiting five missing rawtext elements (noscript, xmp, noembed, noframes, iframe) in the SAFE_FOR_XML regex. Attackers can include payloads like </noscript><img src=x onerror=alert(1)> in attribute values to execute JavaScript when sanitized output is placed inside these unprotected rawtext contexts.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free