En resumen
- CVE-2026-102997 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a pypdf, pypdf (pypdf project).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.34%, mayor que el 27.6% de las vulnerabilidades.
- Solución: actualizar a 6.18.1 o posterior.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.18.1
| 6.18.1
|
| pypdf | < 6.18.1
| 6.18.1
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires a partially malformed /FlateDecode stream, where the byte-by-byte decompression is used.
Patches
This has been fixed in pypdf==6.18.1.
Workarounds
If you cannot upgrade yet, consider applying the changes from PR #4073.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to 6.18.1, a crafted PDF containing a partially malformed /FlateDecode stream with padded data can force pypdf/filters.py to use inefficient byte-by-byte decompression while the earlier recovery counter fails to advance for bytes that successfully decode, causing long runtimes and application unavailability. This is a residual issue after the malformed FlateDecode recovery fix. This issue is fixed in version 6.18.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free