En resumen
- CVE-2026-102999 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a pypdf, pypdf (pypdf project).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.35%, mayor que el 28.4% de las vulnerabilidades.
- Solución: actualizar a 6.19.0 o posterior.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.19.0
| 6.19.0
|
| pypdf | < 6.19.0
| 6.19.0
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires accessing the embedded files through the dictionary-based API.
Patches
This has been fixed in pypdf==6.19.0.
Workarounds
If you cannot upgrade yet, consider applying the changes from PR #4081.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to 6.19.0, a crafted PDF containing many embedded files can cause the dictionary-based attachments API in pypdf/_doc_common.py to reparse the full attachment list for each content lookup, producing repeated work and long runtimes when an application accesses the embedded-file mapping. This issue is fixed in version 6.19.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free