En resumen
- CVE-2026-106492 es una vulnerabilidad MEDIO (CVSS 6.5) que afecta a backstage (linuxfoundation), backstage/backend-defaults (linuxfoundation), @backstage/backend-defaults.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.21%, mayor que el 10.9% de las vulnerabilidades.
- Solución: actualizar a 1.54.6, 1.49.6, 0.17.8, 0.16.1 o posterior.
Description
Impact
An external service credential configured with access restrictions (e.g., read-only) could bypass those restrictions by routing requests through plugin delegation paths. This could allow a restricted service to perform operations beyond its intended scope, including write operations on plugins it was restricted to read-only access for.
Patches
Patched in @backstage/backend-defaults version 0.17.8
Workarounds
If you're unable to upgrade immediately:
- If practical, replace restricted credentials with separate, purpose-specific unrestricted credentials scoped to trusted consumers.
- Restrict network-level access to Backstage backend API endpoints to trusted callers only.
NVD description
Backstage is an open framework for building developer portals. Prior to 0.16.1 and 0.17.8, the @backstage/backend-defaults package is affected by improper preservation of access restrictions during service credential delegation. An external service credential configured with access restrictions (e.g., read-only) could bypass those restrictions by routing requests through plugin delegation paths. This could allow a restricted service to perform operations beyond its intended scope, including write operations on plugins it was restricted to read-only access for. This issue is fixed in versions 0.16.1 and 0.17.8.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free