En resumen
- CVE-2026-106509 es una vulnerabilidad ALTO (CVSS 8.8) que afecta a backstage (linuxfoundation), backstage plugin-techdocs-node (linuxfoundation), @backstage/plugin-techdocs-node.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.52%, mayor que el 44.0% de las vulnerabilidades.
- Solución: actualizar a 1.54.6, 1.50.5, 1.15.4, 1.14.6 o posterior.
Description
Impact
When TechDocs is configured to build documentation locally or in a container, a user with write access to a registered repository can include configuration values in mkdocs.yml that cause arbitrary code execution during the documentation build process.
Patches
Patched in @backstage/plugin-techdocs-node version 1.15.4
Workarounds
- Configure TechDocs with
techdocs.generator.runIn: 'docker' instead of 'local' to provide container isolation, though this does not fully mitigate the risk.
- Restrict write access to repositories registered in the Backstage catalog to trusted users.
NVD description
Backstage is an open framework for building developer portals. Prior to 1.14.6, the @backstage/plugin-techdocs-node package is affected by improper validation of mkdocs theme configuration in techdocs. When TechDocs is configured to build documentation locally or in a container, a user with write access to a registered repository can include configuration values in mkdocs.yml that cause arbitrary code execution during the documentation build process. This issue is fixed in versions 1.14.6 and 1.15.4.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free