En resumen
- CVE-2026-107302 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a msgpack5.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.52%, mayor que el 44.5% de las vulnerabilidades.
- Solución: actualizar a 6.1.0 o posterior.
| Package | Affected versions | Patched versions |
|---|
| msgpack5 npm | ≥ 4.1.0, < 6.1.0
| 6.1.0
|
Description
Impact
A truncated map32 header causes an out-of-bounds buffer read and throws RangeError instead of IncompleteBufferError. Applications that rely on IncompleteBufferError to wait for additional bytes may terminate a request, stream, or worker unexpectedly. No adjacent memory is disclosed because the buffer implementation checks bounds.
Patches
The decoder now validates the complete five-byte map32 header before reading its length and reports truncated input as IncompleteBufferError.
Workarounds
Require at least five bytes before decoding a value beginning with 0xdf, or catch RangeError and treat it as incomplete input only for truncated map32 headers.
NVD description
msgpack5 is a msgpack v5 implementation for node.js and the browser. Prior to 6.1.0, the decoder reads the four-byte length of a map32 value before validating that the complete five-byte header is available. A truncated map32 header therefore causes a checked out-of-bounds buffer read and throws RangeError instead of IncompleteBufferError, which can unexpectedly terminate a request, stream, or worker in applications that wait for additional bytes after IncompleteBufferError. There is no adjacent-memory disclosure because the buffer implementation checks bounds. This issue is fixed in version 6.1.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free