En resumen
- CVE-2026-109855 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a undici (nodejs), undici.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.28%, mayor que el 20.4% de las vulnerabilidades.
- Solución: actualizar a 8.11.2 o posterior.
| Package | Affected versions | Patched versions |
|---|
| undici | ≥ 8.11.0, < 8.11.2
| 8.11.2
|
| undici npm | ≥ 8.11.0, < 8.11.2
| 8.11.2
|
Description
Impact
undici's experimental WebSocket client (enabled by default via allowH2: true) crashes the Node.js process when it connects to a malicious server over HTTP/2. If the server answers the WebSocket upgrade with a response that fails handshake validation, undici aborts the request, but the abort is a no-op because the request is already marked completed, so the underlying ClientHttp2Stream is left open with no error listener. When the server then destroys the connection, the orphaned stream emits an unhandled error and the process exits. A remote, unauthenticated server can therefore deny service to any client that opens a WebSocket to it over HTTP/2. undici 8.11.0 and 8.11.1 are affected; the regression was introduced in 8.11.0.
Patches
Upgrade to 8.11.2.
Workarounds
Set allowH2: false to disable HTTP/2 for WebSocket connections, or avoid opening WebSocket connections to untrusted servers, until upgrading.
NVD description
undici is an HTTP client library for Node.js. In versions 8.11.0 and 8.11.1, its experimental WebSocket client, which is enabled by default when HTTP/2 is allowed, mishandles a failed WebSocket handshake over HTTP/2: the request is already marked completed, so the abort becomes a no-op and the underlying HTTP/2 stream is left open with no error listener. When a malicious server then destroys the connection, the orphaned stream emits an unhandled error and the Node.js process exits. A remote, unauthenticated server can therefore crash any client that opens a WebSocket to it over HTTP/2, resulting in a denial of service. The issue is fixed in undici 8.11.2, and users should upgrade to 8.11.2 or later. As a workaround, set allowH2 to false to disable HTTP/2 for WebSocket connections, or avoid opening WebSocket connections to untrusted servers.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free