En resumen
- CVE-2026-113791 es una vulnerabilidad MEDIO (CVSS 6.0) que afecta a pypdf.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.39%, mayor que el 33.3% de las vulnerabilidades.
- Solución: actualizar a 6.21.0 o posterior.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.21.0
| 6.21.0
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to large memory usage. This requires parsing content streams with many small operations.
Patches
This has been fixed in pypdf==6.21.0.
Workarounds
If you cannot upgrade yet, consider applying the changes from PR #4218.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to 6.21.0, an attacker can craft a PDF containing a content stream with many small operations, causing parsing to consume large amounts of memory. This issue is fixed in version 6.21.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free