En resumen
- CVE-2026-11500 es una vulnerabilidad MEDIO (CVSS 5.0) que afecta a github.com/weaviate/weaviate.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.34%, mayor que el 27.3% de las vulnerabilidades.
- Solución: actualizar a 1.38.0-rc.0 o posterior.
Description
A vulnerability was identified in Weaviate up to 1.37.7. This vulnerability affects the function validateConfig of the file usecases/auth/authentication/apikey/client.go of the component Static API Key Handler. The manipulation of the argument StaticApiKey leads to authorization bypass. It is possible to initiate the attack remotely. The complexity of an attack is rather high. It is stated that the exploitability is difficult. The exploit is publicly available and might be used. Upgrading to version 1.38.0-rc.0 is able to resolve this issue. The identifier of the patch is 40f2cc32279f0f8a51016c3c6870a2c0c808e6c0. You should upgrade the affected component.
NVD description
A vulnerability was identified in Weaviate up to 1.37.7. This vulnerability affects the function validateConfig of the file usecases/auth/authentication/apikey/client.go of the component Static API Key Handler. The manipulation of the argument StaticApiKey leads to authorization bypass. It is possible to initiate the attack remotely. The complexity of an attack is rather high. It is stated that the exploitability is difficult. The exploit is publicly available and might be used. Upgrading to version 1.38.0-rc.0 is able to resolve this issue. The identifier of the patch is 40f2cc32279f0f8a51016c3c6870a2c0c808e6c0. You should upgrade the affected component.
Más vulnerabilidades de github.com/weaviate/weaviate
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free