En resumen
- CVE-2026-22750 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a org.springframework.cloud:spring-cloud-gateway, spring cloud gateway (vmware).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.22%, mayor que el 12.2% de las vulnerabilidades.
- Solución: actualizar a 4.2.1 o posterior.
Description
When configuring SSL bundles in Spring Cloud Gateway by using the configuration property spring.ssl.bundle, the configuration was silently ignored and the default SSL configuration was used instead.
Note: The 4.2.x branch is no longer under open source support. If you are using Spring Cloud Gateway 4.2.0 and are not an enterprise customer, you can upgrade to any Spring Cloud Gateway 4.2.x release newer than 4.2.0 available on Maven Centeral https://repo1.maven.org/maven2/org/springframework/cloud/spring-cloud-gateway/ . Ideally, if you are not an enterprise customer, you should be upgrading to 5.0.2 or 5.1.1, which are the current supported open source releases.
NVD description
When configuring SSL bundles in Spring Cloud Gateway by using the configuration property spring.ssl.bundle, the configuration was silently ignored and the default SSL configuration was used instead.
Note: The 4.2.x branch is no longer under open source support. If you are using Spring Cloud Gateway 4.2.0 and are not an enterprise customer, you can upgrade to any Spring Cloud Gateway 4.2.x release newer than 4.2.0 available on Maven Centeral https://repo1.maven.org/maven2/org/springframework/cloud/spring-cloud-gateway/ . Ideally if you are not an enterprise customer, you should be upgrading to 5.0.2 or 5.1.1 which are the current supported open source releases.
Más vulnerabilidades de org.springframework.cloud:spring-cloud-gateway
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free