En resumen
- CVE-2026-24764 es una vulnerabilidad BAJO (CVSS 3.7) que afecta a openclaw (openclaw), openclaw.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.24%, mayor que el 15.1% de las vulnerabilidades.
- Solución: actualizar a 2026.2.3 o posterior.
| Package | Affected versions | Patched versions |
|---|
| openclaw | < 2026.2.3
| 2026.2.3
|
| openclaw npm | < 2026.2.3
| 2026.2.3
|
Description
Summary
When the Slack integration is enabled, Slack channel metadata (topic/description) could be incorporated into the model's system prompt.
Impact
Prompt injection is a documented risk for LLM-driven systems. This issue increased the injection surface by allowing untrusted Slack channel metadata to be treated as higher-trust system input.
This is relevant only for deployments that enable Slack. In deployments where tool execution is enabled, a successful injection could lead to unintended tool invocations and/or unintended data exposure.
Affected Packages / Versions
Patched Versions
- npm:
openclaw >= 2026.2.3
Mitigation
- If you do not use Slack: no action required.
- If you use Slack: upgrade to a patched version.
Fix Commit(s)
- 35eb40a7000b59085e9c638a80fd03917c7a095e
Thanks @KonstantinMirin for reporting.
NVD description
OpenClaw (formerly Clawdbot) is a personal AI assistant users run on their own devices. In versions 2026.2.2 and below, when the Slack integration is enabled, channel metadata (topic/description) can be incorporated into the model's system prompt. Prompt injection is a documented risk for LLM-driven systems. This issue increases the injection surface by allowing untrusted Slack channel metadata to be treated as higher-trust system input. This issue has been fixed in version 2026.2.3.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free