En resumen
- CVE-2026-24844 es una vulnerabilidad ALTO (CVSS 8.8) que afecta a chainguard.dev/melange, melange (chainguard).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.20%, mayor que el 9.6% de las vulnerabilidades.
- Solución: actualizar a 0.40.3 o posterior.
Description
An attacker who can provide build input values, but not modify pipeline definitions, could execute arbitrary shell commands if the pipeline uses ${{vars.*}} or ${{inputs.*}} substitutions in working-directory. The field is embedded into shell scripts without proper quote escaping.
Fix: Fixed with e51ca30c, Released.
Acknowledgements
melange thanks Oleh Konko from 1seal for discovering and reporting this issue.
NVD description
melange allows users to build apk packages using declarative pipelines. From version 0.3.0 to before 0.40.3, an attacker who can provide build input values, but not modify pipeline definitions, could execute arbitrary shell commands if the pipeline uses ${{vars.*}} or ${{inputs.*}} substitutions in working-directory. The field is embedded into shell scripts without proper quote escaping. This issue has been patched in version 0.40.3.
Más vulnerabilidades de chainguard.dev/melange
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free