En resumen
- CVE-2026-25631 es una vulnerabilidad MEDIO (CVSS 6.5) que afecta a n8n (n8n), n8n.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.30%, mayor que el 23.3% de las vulnerabilidades.
- Solución: actualizar a 1.121.0 o posterior.
| Package | Affected versions | Patched versions |
|---|
| n8n | < 1.121.0
| 1.121.0
|
| n8n npm | < 1.121.0
| 1.121.0
|
Description
Impact
A vulnerability in the HTTP Request node's credential domain validation allowed an authenticated attacker to send requests with credentials to unintended domains, potentially leading to credential exfiltration.
This only might affect user who have credentials that use wildcard domain patterns (e.g., *.example.com) in the "Allowed domains" setting.
Patches
This issue is fixed in version 1.121.0 and later. All users are strongly encouraged to upgrade.
Workarounds
Until projects can upgrade:
- Replace wildcard domain patterns with explicit domain listings in HTTP Request credentials
- Review and restrict workflow creation/modification permissions to trusted users only
- Audit existing workflows using HTTP Request nodes with domain-restricted credentials
n8n has adopted CVSS 4.0 as primary score for all security advisories. CVSS 3.1 vector strings are provided for backward compatibility.
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
NVD description
n8n is an open source workflow automation platform. Prior to 1.121.0, there is a vulnerability in the HTTP Request node's credential domain validation allowed an authenticated attacker to send requests with credentials to unintended domains, potentially leading to credential exfiltration. This only might affect user who have credentials that use wildcard domain patterns (e.g., *.example.com) in the "Allowed domains" setting. This issue is fixed in version 1.121.0 and later.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free