En resumen
- CVE-2026-25632 es una vulnerabilidad CRÍTICO (CVSS 10.0) que afecta a epyt-flow, epyt-flow (waterfutures).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.81%, mayor que el 56.8% de las vulnerabilidades.
- Solución: actualizar a 0.16.1 o posterior.
| Package | Affected versions | Patched versions |
|---|
| epyt-flow PyPI | < 0.16.1
| 0.16.1
|
| epyt-flow | < 0.16.1
| 0.16.1
|
Description
Impact
EPyT-Flow’s REST API parses attacker-controlled JSON request bodies using a custom deserializer (my_load_from_json) that supports a type field. When type is present, the deserializer dynamically imports an attacker-specified module/class and instantiates it with attacker-supplied arguments. This allows invoking dangerous classes such as subprocess.Popen, which can lead to OS command execution during JSON parsing. This also affects the loading of JSON files.
Patches
EPyT-Flow has been patched in 0.16.1 -- affects all versions <= 0.16.0
Workarounds
Do not load any JSON from untrusted sources and do not expose the REST API.
Credits
EPyT-Flow thanks Jarrett Chan (@syphonetic) for detecting and reporting the bug.
NVD description
EPyT-Flow is a Python package designed for the easy generation of hydraulic and water quality scenario data of water distribution networks. Prior to 0.16.1, EPyT-Flow’s REST API parses attacker-controlled JSON request bodies using a custom deserializer (my_load_from_json) that supports a type field. When type is present, the deserializer dynamically imports an attacker-specified module/class and instantiates it with attacker-supplied arguments. This allows invoking dangerous classes such as subprocess.Popen, which can lead to OS command execution during JSON parsing. This also affects the loading of JSON files. This vulnerability is fixed in 0.16.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free