En resumen
- CVE-2026-26974 es una vulnerabilidad CRÍTICO (CVSS 9.8) que afecta a slyde (slyde.js), @tygo-van-den-hurk/slyde.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.61%, mayor que el 49.1% de las vulnerabilidades.
- Solución: actualizar a 0.0.5 o posterior.
Description
Impact
This is a remote code execution (RCE) vulnerability. Node.js automatically imports **/*.plugin.{js,mjs} files including those from node_modules, so any malicious package with a .plugin.js file could execute arbitrary code when installed or required. All projects using this loading behavior are affected, especially those installing untrusted packages.
Patches
The issue has been patched in v0.0.5. Users should upgrade to v0.0.5 or later to mitigate the vulnerability.
Workarounds
- Audit and restrict which packages are installed in
node_modules.
References
NVD description
Slyde is a program that creates animated presentations from XML. In versions 0.0.4 and below, Node.js automatically imports **/*.plugin.{js,mjs} files including those from node_modules, so any malicious package with a .plugin.js file can execute arbitrary code when installed or required. All projects using this loading behavior are affected, especially those installing untrusted packages. This issue has been fixed in version 0.0.5. To workaround this issue, users can audit and restrict which packages are installed in node_modules.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free