En resumen
- CVE-2026-27937 es una vulnerabilidad BAJO (CVSS 3.1) que afecta a october/system.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.14%, mayor que el 3.7% de las vulnerabilidades.
- Solución: actualizar a 3.7.16 o posterior.
| Package | Affected versions | Patched versions |
|---|
| october/system Packagist | ≥ 4.0.0< 3.7.16
| 3.7.16
|
Description
A reflected Cross-Site Scripting (XSS) vulnerability was identified in the backend DataTable widget where a query parameter was rendered without proper output escaping.
Impact
- Reflected XSS only, no stored/persistent component
- The backend URL prefix is customizable and must be known or guessed by the attacker
- Requires an authenticated backend user to visit a crafted URL
- No direct access is gained without social engineering
Patches
The vulnerability has been patched in v3.7.16 and v4.1.16. The affected parameter is now properly escaped. All users are encouraged to upgrade to the latest patched version.
Workarounds
- Use a non-default backend URL prefix (recommended as standard practice)
- Implement a Content Security Policy (CSP) for backend pages
NVD description
October is a Content Management System (CMS) and web platform. Prior to 3.7.16 and 4.1.16, a reflected Cross-Site Scripting (XSS) vulnerability was identified in the backend DataTable widget where a query parameter was rendered without proper output escaping. This vulnerability is fixed in 3.7.16 and 4.1.16.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free