En resumen
- CVE-2026-27971 es una vulnerabilidad CRÍTICO (CVSS 9.8) que afecta a qwik (qwik), @builder.io/qwik.
- Probabilidad de explotación en los próximos 30 días (EPSS): 5.5%, mayor que el 92.8% de las vulnerabilidades.
- Solución: actualizar a 1.19.1 o posterior.
Description
Summary
qwik <=1.19.0 is vulnerable to RCE due to an unsafe deserialization vulnerability in the server$ RPC mechanism that allows any unauthenticated user to execute arbitrary code on the server with a single HTTP request. Affects any deployment where require() is available at runtime.
Impact
NVD description
Qwik is a performance focused javascript framework. qwik <=1.19.0 is vulnerable to RCE due to an unsafe deserialization vulnerability in the server$ RPC mechanism that allows any unauthenticated user to execute arbitrary code on the server with a single HTTP request. Affects any deployment where require() is available at runtime. This vulnerability is fixed in 1.19.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free