En resumen
- CVE-2026-28438 es una vulnerabilidad CRÍTICO (CVSS 9.8) que afecta a cocoindex, cocoindex (cocoindex).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.32%, mayor que el 25.4% de las vulnerabilidades.
- Solución: actualizar a 0.3.34 o posterior.
| Package | Affected versions | Patched versions |
|---|
| cocoindex PyPI | < 0.3.34
| 0.3.34
|
| cocoindex | < 0.3.34
| 0.3.34
|
Description
Impact
The Doris target connector didn't verify the configured table name before creating some SQL statements (ALTER TABLE). So, in the application code, if the table name is provided by an untrusted upstream, it expose vulnerability to SQL injection when target schema change.
Patches
Yes, it's fixed in cocoindex 0.3.34: we start to validate table names passed to Doris target at entry point and error out immediately if it's not a valid identifier.
Workarounds
Users should make sure table names used to configure CocoIndex targets are valid, regardless of this fix. Which means
- The table name comes from a trusted source (e.g. for most cases it's just a fixed string literal).
- Even if it comes from an untrusted source (e.g. provided by end user), it should be validated before using it to configure the Doris target for CocoIndex.
NVD description
CocoIndex is a data transformation framework for AI. Prior to version 0.3.34, the Doris target connector didn't verify the configured table name before creating some SQL statements (ALTER TABLE). So, in the application code, if the table name is provided by an untrusted upstream, it expose vulnerability to SQL injection when target schema change. This issue has been patched in version 0.3.34.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free