En resumen
- CVE-2026-28563 es una vulnerabilidad MEDIO (CVSS 4.3) que afecta a apache-airflow, airflow (apache).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.46%, mayor que el 39.6% de las vulnerabilidades.
- Solución: actualizar a 3.1.8 o posterior.
| Package | Affected versions | Patched versions |
|---|
| apache-airflow PyPI | ≥ 3.0.0, < 3.1.8
| 3.1.8
|
| airflow | ≥ 3.0.0, < 3.1.8
| 3.1.8
|
Description
Apache Airflow versions 3.1.0 through 3.1.7 /ui/dependencies endpoint returns the full DAG dependency graph without filtering by authorized DAG IDs. This allows an authenticated user with only DAG Dependencies permission to enumerate DAGs they are not authorized to view.
Users are recommended to upgrade to Apache Airflow 3.1.8 or later, which resolves this issue.
NVD description
Apache Airflow versions 3.1.0 through 3.1.7 /ui/dependencies endpoint returns the full DAG dependency graph without filtering by authorized DAG IDs. This allows an authenticated user with only DAG Dependencies permission to enumerate DAGs they are not authorized to view.
Users are recommended to upgrade to Apache Airflow 3.1.8 or later, which resolves this issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free