En resumen
- CVE-2026-28779 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a apache-airflow, airflow (apache).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.70%, mayor que el 53.3% de las vulnerabilidades.
- Solución: actualizar a 3.1.8 o posterior.
| Package | Affected versions | Patched versions |
|---|
| apache-airflow PyPI | ≥ 3.0.0, < 3.1.8
| 3.1.8
|
| airflow | ≥ 3.0.0, < 3.1.8
| 3.1.8
|
Description
Apache Airflow versions 3.1.0 through 3.1.7 session token (_token) in cookies is set to path=/ regardless of the configured [webserver] base_url or [api] base_url.
This allows any application co-hosted under the same domain to capture valid Airflow session tokens from HTTP request headers, allowing full session takeover without attacking Airflow itself.
Users are recommended to upgrade to Apache Airflow 3.1.8 or later, which resolves this issue.
NVD description
Apache Airflow versions 3.1.0 through 3.1.7 session token (_token) in cookies is set to path=/ regardless of the configured [webserver] base_url or [api] base_url.
This allows any application co-hosted under the same domain to capture valid Airflow session tokens from HTTP request headers, allowing full session takeover without attacking Airflow itself.
Users are recommended to upgrade to Apache Airflow 3.1.8 or later, which resolves this issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free