En resumen
- CVE-2026-29194 es una vulnerabilidad ALTO (CVSS 8.1) que afecta a github.com/gravitl/netmaker, netmaker (gravitl).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.47%, mayor que el 40.9% de las vulnerabilidades.
- Solución: actualizar a 1.5.0 o posterior.
Description
The Authorise middleware in Netmaker incorrectly validates host JWT tokens. When a route permits host authentication (hostAllowed=true), a valid host token bypasses all subsequent authorisation checks without verifying that the host is authorised to access the specific requested resource. Any entity possessing knowledge of object identifiers (node IDs, host IDs) can craft a request with an arbitrary valid host token to access, modify, or delete resources belonging to other hosts. Affected endpoints include node info retrieval, host deletion, MQTT signal transmission, fallback host updates, and failover operations.
Credits
Artem Danilov (Positive Technologies)
NVD description
Netmaker makes networks with WireGuard. Prior to version 1.5.0, the Authorize middleware in Netmaker incorrectly validates host JWT tokens. When a route permits host authentication (hostAllowed=true), a valid host token bypasses all subsequent authorization checks without verifying that the host is authorized to access the specific requested resource. Any entity possessing knowledge of object identifiers (node IDs, host IDs) can craft a request with an arbitrary valid host token to access, modify, or delete resources belonging to other hosts. Affected endpoints include node info retrieval, host deletion, MQTT signal transmission, fallback host updates, and failover operations. This issue has been patched in version 1.5.0.
Más vulnerabilidades de github.com/gravitl/netmaker
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free