En resumen
- CVE-2026-30229 es una vulnerabilidad ALTO (CVSS 7.2) que afecta a parse-server (parseplatform), parse-server.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.43%, mayor que el 37.1% de las vulnerabilidades.
- Solución: actualizar a 8.6.6, 9.5.0-alpha.4 o posterior.
| Package | Affected versions | Patched versions |
|---|
| parse-server | = 9.5.0≥ 9.0.0, ≤ 9.4.1< 8.6.6
| 8.6.6
|
| parse-server npm | ≥ 9.0.0, < 9.5.0-alpha.4< 8.6.6
| 9.5.0-alpha.48.6.6
|
Description
Impact
The readOnlyMasterKey can call POST /loginAs to obtain a valid session token for any user. This allows a read-only credential to impersonate arbitrary users with full read and write access to their data. Any Parse Server deployment that uses readOnlyMasterKey is affected.
Patches
The fix adds a check to the /logInAs handler.
Workarounds
There is no workaround other than not using readOnlyMasterKey.
References
NVD description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.6 and 9.5.0-alpha.4, the readOnlyMasterKey can call POST /loginAs to obtain a valid session token for any user. This allows a read-only credential to impersonate arbitrary users with full read and write access to their data. Any Parse Server deployment that uses readOnlyMasterKey is affected. This issue has been patched in versions 8.6.6 and 9.5.0-alpha.4.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free