| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.skywalking:server-core | ≥ 9.7.0, < 10.4.0 | 10.4.0 |
| skywalking | ≥ 9.7.0, < 10.4.0 | 10.4.0 |
The SkyWalking OAP /debugging/config/dump endpoint may leak sensitive configuration information of MySQL/PostgreSQL.
This issue affects Apache SkyWalking: from 9.7.0 through 10.3.0.
Users are recommended to upgrade to version 10.4.0, which fixes the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free