En resumen
- CVE-2026-30854 es una vulnerabilidad MEDIO (CVSS 5.3) que afecta a parse-server (parseplatform), parse-server.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.31%, mayor que el 23.5% de las vulnerabilidades.
- Solución: actualizar a 9.5.0, 9.5.0-alpha.10 o posterior.
| Package | Affected versions | Patched versions |
|---|
| parse-server | = 9.3.1= 9.5.0≥ 9.4.0, < 9.5.0
| 9.5.0
|
| parse-server npm | ≥ 9.3.1-alpha.3, < 9.5.0-alpha.10
| 9.5.0-alpha.10
|
Description
Impact
When graphQLPublicIntrospection is disabled, __type queries nested inside inline fragments (e.g. ... on Query { __type(name:"User") { name } }) bypass the introspection control, allowing unauthenticated users to perform type reconnaissance. __schema introspection is not affected.
Patches
The check was changed from a flat iteration over root-level selections to a recursive walk of all selection sets, detecting __type inside inline fragments at any depth.
Workarounds
Require master key authentication at the network layer (e.g. reverse proxy) for the GraphQL endpoint.
References
NVD description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. From version 9.3.1-alpha.3 to before version 9.5.0-alpha.10, when graphQLPublicIntrospection is disabled, __type queries nested inside inline fragments (e.g. ... on Query { __type(name:"User") { name } }) bypass the introspection control, allowing unauthenticated users to perform type reconnaissance. __schema introspection is not affected. This issue has been patched in version 9.5.0-alpha.10.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free