En resumen
- CVE-2026-30947 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a parse-server (parseplatform), parse-server.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.44%, mayor que el 38.5% de las vulnerabilidades.
- Solución: actualizar a 9.5.2, 8.6.16, 9.5.2-alpha.3 o posterior.
| Package | Affected versions | Patched versions |
|---|
| parse-server | = 9.5.2≥ 9.0.0, < 9.5.2< 8.6.16
| 9.5.28.6.16
|
| parse-server npm | ≥ 9.0.0, < 9.5.2-alpha.3< 8.6.16
| 9.5.2-alpha.38.6.16
|
Description
Impact
Class-level permissions (CLP) are not enforced for LiveQuery subscriptions. An unauthenticated or unauthorized client can subscribe to any LiveQuery-enabled class and receive real-time events for all objects, regardless of CLP restrictions.
All Parse Server deployments that use LiveQuery with class-level permissions are affected. Data intended to be restricted by CLP is leaked to unauthorized subscribers in real time.
Patches
The fix enforces CLP before creating the subscription and during event delivery.
Workarounds
Disable LiveQuery for classes that use CLP restrictions by removing them from the liveQuery.classNames server configuration.
References
NVD description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.3 and 8.6.16, class-level permissions (CLP) are not enforced for LiveQuery subscriptions. An unauthenticated or unauthorized client can subscribe to any LiveQuery-enabled class and receive real-time events for all objects, regardless of CLP restrictions. All Parse Server deployments that use LiveQuery with class-level permissions are affected. Data intended to be restricted by CLP is leaked to unauthorized subscribers in real time. This vulnerability is fixed in 9.5.2-alpha.3 and 8.6.16.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free