En resumen
- CVE-2026-30949 es una vulnerabilidad ALTO (CVSS 8.8) que afecta a parse-server (parseplatform), parse-server.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.45%, mayor que el 39.3% de las vulnerabilidades.
- Solución: actualizar a 9.5.2, 8.6.18, 9.5.2-alpha.5 o posterior.
| Package | Affected versions | Patched versions |
|---|
| parse-server | = 9.5.2≥ 9.0.0, < 9.5.2< 8.6.18
| 9.5.28.6.18
|
| parse-server npm | ≥ 9.0.0, < 9.5.2-alpha.5< 8.6.18
| 9.5.2-alpha.58.6.18
|
Description
Impact
The Keycloak authentication adapter does not validate the azp (authorized party) claim of Keycloak access tokens against the configured client-id. A valid access token issued by the same Keycloak realm for a different client application can be used to authenticate as any user on the Parse Server that uses the Keycloak adapter. This enables cross-application account takeover in multi-client Keycloak realms.
All Parse Server deployments that use the Keycloak authentication adapter with a Keycloak realm that has multiple client applications are affected.
Patches
The fix replaces the userinfo HTTP call with local JWT verification and enforces azp claim validation against the configured client-id.
Workarounds
None.
References
NVD description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.5 and 8.6.18, the Keycloak authentication adapter does not validate the azp (authorized party) claim of Keycloak access tokens against the configured client-id. A valid access token issued by the same Keycloak realm for a different client application can be used to authenticate as any user on the Parse Server that uses the Keycloak adapter. This enables cross-application account takeover in multi-client Keycloak realms. All Parse Server deployments that use the Keycloak authentication adapter with a Keycloak realm that has multiple client applications are affected. This vulnerability is fixed in 9.5.2-alpha.5 and 8.6.18.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free