En resumen
- CVE-2026-32061 es una vulnerabilidad MEDIO (CVSS 4.4) que afecta a openclaw (openclaw), openclaw.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.15%, mayor que el 4.3% de las vulnerabilidades.
- Solución: actualizar a 2026.2.17 o posterior.
| Package | Affected versions | Patched versions |
|---|
| openclaw | < 2026.2.17
| 2026.2.17
|
| openclaw npm | < 2026.2.17
| 2026.2.17
|
Description
Vulnerability
Path traversal in config $include resolution allowed arbitrary local file reads outside the config directory boundary (CWE-22).
Attack Vectors
- If an attacker can modify OpenClaw config, they can set
$include to absolute paths (for example /etc/passwd) and read files accessible to the OpenClaw process.
- If an attacker can modify OpenClaw config, they can use traversal paths (for example
../../...) to escape the config directory.
- If an attacker can create symlinks inside the config directory, they can point includes to external files unless real-path checks are enforced.
- Impact scope is bounded by the file permissions of the OpenClaw runtime user; this is not an unauthenticated remote-only vector by itself.
Impact
A successful exploit can expose local secrets and credentials readable by the OpenClaw process user, including API keys and private config material.
Affected Packages / Versions
- Package:
openclaw (npm)
- Vulnerable versions:
<=2026.2.15
- Patched versions:
>=2026.2.17
Fix Commit(s)
d1c00dbb7c64a39e205464dae7f2a068420e91c1
Release Process Note
Patched version is pre-set to 2026.2.17. Once npm release 2026.2.17 is available, this advisory is ready to publish.
OpenClaw thanks @aether-ai-agent for reporting.
NVD description
OpenClaw versions prior to 2026.2.17 contain a path traversal vulnerability in the $include directive resolution that allows reading arbitrary local files outside the config directory boundary. Attackers with config modification capabilities can exploit this by specifying absolute paths, traversal sequences, or symlinks to access sensitive files readable by the OpenClaw process user, including API keys and credentials.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free