En resumen
- CVE-2026-32248 es una vulnerabilidad CRÍTICO (CVSS 9.8) que afecta a parse-server (parseplatform), parse-server.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.64%, mayor que el 50.9% de las vulnerabilidades.
- Solución: actualizar a 9.6.0, 8.6.38, 9.6.0-alpha.12 o posterior.
| Package | Affected versions | Patched versions |
|---|
| parse-server | = 9.6.0≥ 9.0.0, < 9.6.0< 8.6.38
| 9.6.08.6.38
|
| parse-server npm | ≥ 9.0.0, < 9.6.0-alpha.12< 8.6.38
| 9.6.0-alpha.128.6.38
|
Description
Impact
An unauthenticated attacker can take over any user account that was created with an authentication provider that does not validate the format of the user identifier (e.g. anonymous authentication). By sending a crafted login request, the attacker can cause the server to perform a pattern-matching query instead of an exact-match lookup, allowing the attacker to match an existing user and obtain a valid session token for that user's account. Both MongoDB and PostgreSQL database backends are affected. Any Parse Server deployment that allows anonymous authentication (enabled by default) is vulnerable.
Patches
The fix enforces that the user identifier in authentication data is a string before using it in a database query. Non-string values are rejected with a validation error.
Workarounds
There is no known workaround.
References
NVD description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.12 and 8.6.38, an unauthenticated attacker can take over any user account that was created with an authentication provider that does not validate the format of the user identifier (e.g. anonymous authentication). By sending a crafted login request, the attacker can cause the server to perform a pattern-matching query instead of an exact-match lookup, allowing the attacker to match an existing user and obtain a valid session token for that user's account. Both MongoDB and PostgreSQL database backends are affected. Any Parse Server deployment that allows anonymous authentication (enabled by default) is vulnerable. This vulnerability is fixed in 9.6.0-alpha.12 and 8.6.38.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free