En resumen
- CVE-2026-33498 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a parse-server (parseplatform), parse-server.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.47%, mayor que el 40.7% de las vulnerabilidades.
- Solución: actualizar a 9.6.0, 8.6.55, 9.6.0-alpha.44 o posterior.
| Package | Affected versions | Patched versions |
|---|
| parse-server | = 9.6.0≥ 9.0.0, < 9.6.0< 8.6.55
| 9.6.08.6.55
|
| parse-server npm | ≥ 9.0.0, < 9.6.0-alpha.44< 8.6.55
| 9.6.0-alpha.448.6.55
|
Description
Impact
An attacker can send an unauthenticated HTTP request with a deeply nested query containing logical operators to permanently hang the Parse Server process. The server becomes completely unresponsive and must be manually restarted. This is a bypass of the fix for CVE-2026-32944.
Patches
The query condition nesting depth is now validated before the query enters the transformation pipeline, preventing deeply nested structures from being recursively processed before the existing depth guard can fire.
Workarounds
None.
NVD description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.55 and 9.6.0-alpha.44, an attacker can send an unauthenticated HTTP request with a deeply nested query containing logical operators to permanently hang the Parse Server process. The server becomes completely unresponsive and must be manually restarted. This is a bypass of the fix for CVE-2026-32944. This issue has been patched in versions 8.6.55 and 9.6.0-alpha.44.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free