En resumen
- CVE-2026-33627 es una vulnerabilidad MEDIO (CVSS 6.5) que afecta a parse-server (parseplatform), parse-server.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.39%, mayor que el 33.4% de las vulnerabilidades.
- Solución: actualizar a 9.6.0, 8.6.61, 9.6.0-alpha.55 o posterior.
| Package | Affected versions | Patched versions |
|---|
| parse-server | = 9.6.0≥ 9.0.0, < 9.6.0< 8.6.61
| 9.6.08.6.61
|
| parse-server npm | ≥ 9.0.0, < 9.6.0-alpha.55< 8.6.61
| 9.6.0-alpha.558.6.61
|
Description
Impact
An authenticated user calling GET /users/me receives unsanitized auth data, including sensitive credentials such as MFA TOTP secrets and recovery codes. The endpoint internally uses master-level authentication for the session query, and the master context leaks through to the user data, bypassing auth adapter sanitization. An attacker who obtains a user's session token can extract MFA secrets to generate valid TOTP codes indefinitely.
Patches
The /users/me endpoint now queries the session and user data separately, using the caller's authentication context for the user query so that all security layers apply correctly.
Workarounds
There is no known workaround.
NVD description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.61 and 9.6.0-alpha.55, an authenticated user calling GET /users/me receives unsanitized auth data, including sensitive credentials such as MFA TOTP secrets and recovery codes. The endpoint internally uses master-level authentication for the session query, and the master context leaks through to the user data, bypassing auth adapter sanitization. An attacker who obtains a user's session token can extract MFA secrets to generate valid TOTP codes indefinitely. This issue has been patched in versions 8.6.61 and 9.6.0-alpha.55.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free